chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
I've noticed it happening since version 7.0.6 of Typemock Isolator. It's still happening in 7.0.8, regardless of unit test content (I can start empty solution with test project and sample, empty test created by wizard - it still crashes). The only condition - VS2010 profilers linked with Typemock Isolator. If I unlink them, Autorunner works fine.

What does exactly happen? When I build the project, I get a system window popping up with the following message:
"Typemock.Common.TestRunner has stopped working".

Here are the error's details:
Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01:   typemock.common.testsrunner.exe
  Problem Signature 02:
  Problem Signature 03:   4ffc2c08
  Problem Signature 04:   mscorlib
  Problem Signature 05:   4.0.30319.17626
  Problem Signature 06:   4f9f0e6e
  Problem Signature 07:   1753
  Problem Signature 08:   8
  Problem Signature 09:   System.AccessViolationException
  OS Version:   6.1.7601.
  Locale ID:   1033
  Additional Information 1:   5653
  Additional Information 2:   5653deee4e05ea9f82f4f87bc936dd1e
  Additional Information 3:   aee4
  Additional Information 4:   aee48355a549c1f9ddc51952be86c511

Regardless of Auto Runner problem, Isolator seems to work fine (I run tests in both ReSharper 6.1 test runner and in native VS2010 one). About my setup:

1.) My box is running on Win 7 x64, Enterprise Ed.
2.) I'm running VS2010 in Ultimate version with few add-ons (Reflector, ReSharper, dotTrace, dotCover, Telerik - all of the up-to-date, same with VS itself).
3.) My problem appears when I run VS on both normal and elevated rights.
asked by sebastian.gebski (640 points)

11 Answers

0 votes

Any updated on the issue? Please look into this issue asap.

Thanks & Regards
Teena Sharma
answered by teenasharma (1.4k points)