chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes

Hello,

I followed the guide starting from here https://www.typemock.com/docs/?book=Ipp&page=setting_up_linux.htm in order to install from command line anything required for Isolator++ on Ubuntu.

I'm using Windows 10 with Ubuntu-20.04 WSL2 subsystem.

The installation went smoothly, but after building the examples and define the environment variable LD_BIND_NOW=1, the tests execution crashes with a segfault:

/usr/share/typemock/Examples/LinuxBuild/Debug64$ ./IsolatorExamplesGCC_UsingDynamicLib 

*** Typemock Isolator++ Professional 4.1.4.0 (64bit) ***

Documentation: https://www.typemock.com/docs?book=Ipp

[==========] Running 72 tests from 23 test cases.

[----------] Global test environment set-up.

[----------] 2 tests from GlobalCMethods

[ RUN      ] GlobalCMethods.FakingReturnValueOnGlobalMethod

[       OK ] GlobalCMethods.FakingReturnValueOnGlobalMethod (3 ms)

[ RUN      ] GlobalCMethods.FakingMethodAndUsingRecursiveFake

[       OK ] GlobalCMethods.FakingMethodAndUsingRecursiveFake (0 ms)

[----------] 2 tests from GlobalCMethods (4 ms total)

[----------] 5 tests from ArgumentTests

[ RUN      ] ArgumentTests.UsingThe_MacroForShorthand

[       OK ] ArgumentTests.UsingThe_MacroForShorthand (3 ms)

[ RUN      ] ArgumentTests.UsingTheANY_VALMacroForShorthand

[       OK ] ArgumentTests.UsingTheANY_VALMacroForShorthand (36 ms)

[ RUN      ] ArgumentTests.UsingTheANY_REFMacroForShorthand

[       OK ] ArgumentTests.UsingTheANY_REFMacroForShorthand (0 ms)

[ RUN      ] ArgumentTests.UsingRETToSimulateReturnedValue

[       OK ] ArgumentTests.UsingRETToSimulateReturnedValue (1 ms)

[ RUN      ] ArgumentTests.ValidatingArgumentInSeparateMethod

[       OK ] ArgumentTests.ValidatingArgumentInSeparateMethod (0 ms)

[----------] 5 tests from ArgumentTests (40 ms total)

[----------] 7 tests from AssertingInteraction

[ RUN      ] AssertingInteraction.AssertCallWasMadeOnDependency

[       OK ] AssertingInteraction.AssertCallWasMadeOnDependency (0 ms)

[ RUN      ] AssertingInteraction.AssertCallWasMadeWithSpecificArgumentsOnDependency

[       OK ] AssertingInteraction.AssertCallWasMadeWithSpecificArgumentsOnDependency (0 ms)

[ RUN      ] AssertingInteraction.AssertCallWasMadeWithSpecificArgumentsOnDependencyWithPredicates

[       OK ] AssertingInteraction.AssertCallWasMadeWithSpecificArgumentsOnDependencyWithPredicates (0 ms)

[ RUN      ] AssertingInteraction.AssertCallWasNotMadeOnDependency

[       OK ] AssertingInteraction.AssertCallWasNotMadeOnDependency (0 ms)

[ RUN      ] AssertingInteraction.TimesCalledMethodOnDependency

[       OK ] AssertingInteraction.TimesCalledMethodOnDependency (0 ms)

[ RUN      ] AssertingInteraction.WasNotCalledWithConcreteOutParam

Segmentation fault

Can you point to any direction to solve this problem?
 

Thanks

asked by davege (600 points)

2 Answers

0 votes

Hi,

Unfurtunataly, we don't have intergration with Ubuntu version 20.x.
Our latest version supports up until version 18.x.

Supporting Ubuntu version 20 is in our RoadMap, but I can't give you a time estimation on when it will be released.

Is there anything else I can assist you with?

Cheers,
Alon Sapozhnikov.
Support Specialist.

answered by Alon_TypeMock (8.4k points)
0 votes

I'm utilizing Windows 10 with Ubuntu-20.04 WSL2 subsystem.

The establishment went without a hitch, however in the wake of building the models and characterize the climate variable LD_BIND_NOW=1, the tests execution crashes with a segfault:

Thanks.

Hire AEM Developers

answered by aemoutsource (140 points)

Hi Aemoutsource,

As I answered to the original question, we still don't have support for Ubuntu version 20.
You can download the Ubuntu 18 as WSL on your machine and it will work perfectly.

Cheers,
Alon Sapozhnikov.
Support Specialist.

...